BevSpot Supported Browsers

For the best experience using BevSpot, we recommend using one of the below listed internet browsers. Using the most up to date version of a supported browser will give you all of the functionality and design our team can offer. Using an out-of-date browser may result in limited functionality, or unintended display changes on BevSpot pages.

For Desktop:

  • Chrome (Latest 2 versions)
  • Firefox (Latest 2 versions + ESR)
  • Edge (Latest 2 versions)
  • Safari 9 (Available on OS X 10.9 or later)
  • Internet Explorer 11

For Mobile:

  • Chrome (For Apple and Android devices)
  • Safari

For Mobile Apple Products, we recommend iOS 9 and up (iPhone 4S and later, iPad 2 and later).

Need help identifying what version or browser you have, or updating? Reach out to our team via the chat feature in your account, and we will be happy to help!